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System experiences graphics performance lag when operating in headless mode with an active VCN connection

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Release Date January 19, 2016
Product(s) Affected Kangaroo Mobile Desktop
Operating System Microsoft Windows 10 
Application(s) Affected TightVCN, RealVCN, Intel HD Graphics Driver

NOTICE:

The information in this document, including products and software versions, is current as of the Release Date. This document is subject to change without notice.

Problem Description 

Kangaroo Mobile Desktop systems running an active VNC connection while disconnected from the Kangaroo Dock, or other Expansion Base accessory, may experience a random/intermittent lag in graphics performance. 

While the exact symptoms experienced are highly dependent on the applications being accessed and their use of graphics memory, following are a few of the more notable characteristics of this condition:

  • Delayed or out-of-synch operations between remote and host computers; E.g., a click event on the remotely connected device (such as opening an application) may take up to 2~3 seconds to initiate on the host device.
  • Intermittent (and notably visible) screen refresh
  • An active application window (such as the Chrome browser) may appear washed out or blank immediately upon disconnecting from the dock.

Root Cause

This is a compatibility issue that is known to occur between certain graphics device drivers and remote access software applications, and is directly linked to the manner in which both handle power and resource management under the above described conditions.

While the Intel Graphics driver is known to be operating within specifications (and performing precisely as expected), it's understood that when the primary HDMI device is disconnected from the system (and EDID is no longer present) the Intel Graphics driver responds accordingly by adjusting system resources to invoke certain aspects of its GPU power management plan. 

Note: It should be noted that this problem is not isolated to Intel, and may occur with any GPU Chipset driver and Remote Access application combination where EDID presence is leveraged (by the chipset manufacturer) to effect power/resource management logic.

Workaround/Solution

The only known workarounds to this problem are:

  • Purchasing a 3rd party Headless Plug solution which emulates EDID presence. 
  • Installing the native Microsoft Windows Graphics Driver

The sections that follow outline the detailed procedures required to install the native Microsoft Windows Graphics Driver. 

IMPORTANT NOTE: Native operating system drivers are by design intended to provide generic hardware enabling support for certain devices, and in some cases may not support or take advantage of certain vendor-unique features, resulting in unpredictable behavior.

Key Steps in This Procedure

  1. Uninstalling the Intel HD Graphics Driver
  2. Disabling Driver Updates (for the Intel graphics device)
  3. Installing the Native Graphics Driver; otherwise known as "the Windows in-box Basic Display Adapter driver".
Uninstalling the Intel Graphics Driver
  1. Right-click on the Start  menu icon, and select Device Manager.
  2. Click the arrow next to the Display Adapters device category.
  3. Right-click on the Intel (R) HD Graphics device and select Update Driver Software.
  4. Select the Delete the driver software for this device checkbox and click OK.

Note-1Upon completion Windows will prompt you to restart your computer, at which time the Intel driver will be reinstalled; this is the expected result, and is necessary to ensure certain traces (which are left during the re-installation) can be utilized as part of the next step in this procedure.

Note-1: After restarting your computer it may take the operating system 5~10 mins to re-detect the hardware, locate and re-install the driver; if you wish to accelerate this process you can return to Device Manager, click the Action menu and select Scan for hardware changes. Once the driver is re-installed Windows may prompt you once again to restart your computer; follow the prompts, restart and move onto the next step once complete.

Disabling Windows Updates (for the Intel Driver)

Background

One of the key features of Windows Update is its ability to detect key components within your PC's hardware and automatically locate and install the latest available driver from the hardware manufacturers. This is usually a good thing (and often critically important), as hardware manufacturers frequently release drivers as a means of addressing performance and stability problems; however, in the context of this workaround, since we intend to install the native operating system driver then we need to take specific steps to ensure that Windows Update doesn't undo this work by automatically detecting your graphics hardware and installing the latest Intel driver when you least expect it.  

 

  1. Download the "Show or Hide Updates" troubleshooter package from Microsoft
  2. Launch the package (wushowhide.diagcab) and step through the troubleshooter to hide the Intel Graphics Driver. 
Reference: Microsoft Knowledge Base Article 3073930
Installing the Native Graphics Driver
  1. Right-click on the Start  menu icon, and select Device Manager.
  2. Click the arrow next to the Display Adapters device category, and Right-click on the Intel (R) HD Graphics device and select Update Driver Software.
  3. Select Browse my computer for driver software
  4. Click Browse, and navigate to the folder found in the path outlined below. Select the Display.Inf folder, and click OK.

C:\Windows\System32\DriverStore\FileRepository\display.inf_amd64_944bbb58c2ca7d39

NOTE: The "display.inf_amd64" folder is dynamically created when the Windows operating system is installed, and as such certain characters of the folder name will be unique to your individual system and will not be a precise match with the path provided above. 

  • Once this process is completed, it's recommended that you return to Device Manager to verify the Display Adapter component is correctly displayed as below.

 

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